DSUSB + Canon 40D + Nebulosity Problem

Questions about hardware and software not obtained from Shoestring Astronomy, but related to our products
Post Reply
pegaso0970
Posts: 5
Joined: Thu Oct 02, 2008 3:01 pm

DSUSB + Canon 40D + Nebulosity Problem

Post by pegaso0970 » Fri Oct 03, 2008 2:17 am

Hi, i'm leonardo from Italy.

With the the configuration on the subject i have problem with exposure longer than 30 s. I set the Shutter controlo to DSUSB and all work good with exposure under 30s,(the 40D is setting on "M" and bulb on) if i try to use 31 s the shutter doesn't open and when the time exposure finished Nebulosity try to download the picture (but the picture is never started !!) and after 60s !! it stops to acquiring data, i think for timeout.

For your information before this issue i found the same problem above for each time of exposure if i try to set mirror lockup enable on the 40D (this is the reasons why i bought DSUSB .. snip!!!).

Now I try the situation on Vista and on different PC with XP, the result is the same....i wrote to Stark Labs also...

Some help !!!
Leonardo

dpanderson
Site Admin
Posts: 1040
Joined: Fri Apr 28, 2006 1:34 pm
Location: central Iowa
Contact:

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by dpanderson » Fri Oct 03, 2008 8:33 am

Leonardo,

Have you tried using DSUSBCheck (http://store.shoestringastronomy.com/do ... _setup.exe) to make sure the DSUSB is working properly?
Doug Anderson
Shoestring Astronomy
http://www.ShoestringAstronomy.com

pegaso0970
Posts: 5
Joined: Thu Oct 02, 2008 3:01 pm

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by pegaso0970 » Fri Oct 03, 2008 8:50 am

Thanks for reply.. :D

I tried...but I'd check only the led color and their switching..

But, the question: who shot and gave me a picture when i had setting DSUSB on nebulosity field for the shutter ??
For this reason i suppose then DSUSB work...its possible that DIGICIII bulb internal shot instead of??

dpanderson
Site Admin
Posts: 1040
Joined: Fri Apr 28, 2006 1:34 pm
Location: central Iowa
Contact:

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by dpanderson » Fri Oct 03, 2008 9:20 am

With DSUSBCheck, you can also use the Open and Close Shutter buttons to see if it fires the camera shutter. Give that a try.
Doug Anderson
Shoestring Astronomy
http://www.ShoestringAstronomy.com

pegaso0970
Posts: 5
Joined: Thu Oct 02, 2008 3:01 pm

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by pegaso0970 » Fri Oct 03, 2008 4:22 pm

I tried with DSUSBCheck and open and close shutter doesn't work...only led color and led on/off....whats the problem?

The program found the adapter!!

dpanderson
Site Admin
Posts: 1040
Joined: Fri Apr 28, 2006 1:34 pm
Location: central Iowa
Contact:

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by dpanderson » Sat Oct 04, 2008 6:18 pm

It is possible that the DSUSB output or the cable has become damages. Try pushing the cable in firmly, to make sure it is completely inserted. If that doesn't help out, then I think it is time to let me send you a replacement DSUSB and cable.
Doug Anderson
Shoestring Astronomy
http://www.ShoestringAstronomy.com

pegaso0970
Posts: 5
Joined: Thu Oct 02, 2008 3:01 pm

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by pegaso0970 » Mon Oct 06, 2008 3:45 am

Hi Dan,

the problem is inside the DSUSB, thre's not output from the PIC. I'm electrical engineer and i opened then box and checked the CC inside with the multimeter and DSUSBCheck....

Your prevision its right...and now , Should I refer directly to Italy's revendor or solve the question with you ?

Thanks a lot for your help.

PS. I hope doesn't lose the warranty ...

dpanderson
Site Admin
Posts: 1040
Joined: Fri Apr 28, 2006 1:34 pm
Location: central Iowa
Contact:

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by dpanderson » Mon Oct 06, 2008 7:42 am

Great troubleshooting work. We can take care of this directly. Please send an email with your shipping address to doug@shoestringastronomy.com
Doug Anderson
Shoestring Astronomy
http://www.ShoestringAstronomy.com

pegaso0970
Posts: 5
Joined: Thu Oct 02, 2008 3:01 pm

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by pegaso0970 » Tue Oct 07, 2008 4:03 am

Great.. Thanks a lot....for all

Leonardo

b_carberry
Posts: 6
Joined: Thu Feb 05, 2009 1:49 pm

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by b_carberry » Tue Aug 04, 2009 7:42 am

I am having the same problem with DSUSB and a Cannon 400 XTi Rebel using Nebulosity. When I try to do an exposure over 30 seconds I get the "Warning - set exposure duration to 30s, the limit without a long exposure adapter".

I have reset all my camera functions, so I'm not trying mirror flip up or camera noise reduction. I have run the utility and I can manually control the red and green lights and fire tghe shutter (although I can not close the shutter except in bulb mode). I have selected "Shoestring DSUSB" from the Nebulosity pull-dowm preferences menu, but left all the other settings at default.

Is thsi a camera DSUSB problem or a Nebulosity / DSUSB problem when using a Cannon Rebel XTi?

Advice?

Thanls
Bill Carberry

dpanderson
Site Admin
Posts: 1040
Joined: Fri Apr 28, 2006 1:34 pm
Location: central Iowa
Contact:

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by dpanderson » Tue Aug 04, 2009 7:52 am

From the error message, it sounds like Nebulosity is not connecting to the DSUSB.

When you say the utility, are you referring to our DSUSBCheck, or to Stark Labs' DSLR Shutter? If you have not done so, give DSLR Shutter a try and see if that works properly.
Doug Anderson
Shoestring Astronomy
http://www.ShoestringAstronomy.com

b_carberry
Posts: 6
Joined: Thu Feb 05, 2009 1:49 pm

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by b_carberry » Fri Aug 14, 2009 12:04 pm

Sorry for the delay in replying, but we were on vacation without access to computers or cell phone (it was great)!!!

I have run the DSUSB and it works... can control shutter and light and all. Response from Stark labs was to attach the camera and the DSUSB to the computer before opening Nebulosity, then open Nebulosity, set the adapter to DSUSB and then pick the camera. When I do that I all goes well, until I try to set the exposure over 30 sec, and then it says there is no long exposure adaopter connected to the computer.

At the Table Mt Star Party an guy next to me said he heard that you had to be careful to make sure that anything you put in the USB went to the exact same USB each time, and that I should manually assign the DSUSB to something above Comm 4 (since lowre comm ports are usually assigned to mice, etc).

Since I just ordered the GPUSB I am wondering if I was planning to run them both through a powered hub, is this going to work? And what do you think about the Comm port assignment suggestion... is that necessary?

Thanks

Bill Carberry
b_carberry@yahoo.com

dpanderson
Site Admin
Posts: 1040
Joined: Fri Apr 28, 2006 1:34 pm
Location: central Iowa
Contact:

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by dpanderson » Fri Aug 14, 2009 12:39 pm

Bill,

In my own experience, I have never had issues related to plugging the same device into different USB ports, although I do know that the computer might see it as a new device and need to re-discover it.

The comm port comment confuses me. Comm ports usually refer to the older serial ports and not to USB ports. So, I'm not sure how this has relevance unless you are using a USB-to-serial converter.

Your GPUSB should work just fine. In my own setup, I run a DSUSB, GPUSB, FCUSB all through the same powered hub.
Doug Anderson
Shoestring Astronomy
http://www.ShoestringAstronomy.com

b_carberry
Posts: 6
Joined: Thu Feb 05, 2009 1:49 pm

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by b_carberry » Sat Aug 15, 2009 1:41 pm

Thanks Doug. I got a similar answer, but with a lot more software detail from Craig Stark. I had my Canon EOS Utility program set to automatically open when the camera was plugged into the laptop and Craig suggested that might be the source of the conflict. Even though I was shutting it down as soon as it came up it was still occupying some dark corner of memory or resources that apparently was conflicting with Nebulosity's ability to recognize the DSUSB. Can't explain it any better than I can explain anything else about Windows XP except to say that by de-selecting the auto-start on the EOS Utility my camera, laptop, and DSUSB now all seem to be functioning in harmony with Nebulosity.

The Comm issue was something another astrophotographer threw out as we tried to trouble shoot the problem at the Table Mountain Start Party in July. It was a shot in the proverbial dark that he suggested I ask about. Craig had the same answer as you, and its put to bed (and I learned someting about comm ports that I didn't know).

Thanks.

dpanderson
Site Admin
Posts: 1040
Joined: Fri Apr 28, 2006 1:34 pm
Location: central Iowa
Contact:

Re: DSUSB + Canon 40D + Nebulosity Problem

Post by dpanderson » Sun Aug 16, 2009 7:58 am

Glad to hear that your system is behaving better now. Thanks for the follow-up post so that others may benefit from your experience.

Post Reply