Page 1 of 1

USB2EQ6 to Mac via EQMac

Posted: Mon Oct 10, 2016 3:03 pm
by Applal
I am attempting to use a USB2EQ6 cable, direct from my Mac to my EQ-G Atlas mount via EQMac.
EQMac "sees" the mount, and I can press it's buttons to move the mount in all 4 directions. But when I then launch Sky Safari 5, and go through the setup for telescope routine, I can see that the set up routine "sees" the USB connection.
I select the correct mount type.
I get a connection error -13 (according to the log file).

I have also tried Starry Night Pro7 and get a connection error there as well.

Any thoughts, suggestions, or ideas would be most appreciated.

Re: USB2EQ6 to Mac via EQMac

Posted: Mon Oct 10, 2016 6:05 pm
by dpanderson
Since EQMac can see the mount and you get mount movement in each direction, it sounds like the USB2EQ6 is working properly. Unfortunately I can't give you any other guidance since I am not a Mac owner. Have you tried tech support from the EQMac developer?

Re: USB2EQ6 to Mac via EQMac

Posted: Tue Oct 11, 2016 11:16 am
by Applal
Thank you for your reply. In further communication from EQMac developer, he did set me straight on how to use the Planetarium software.
I was first connecting to the mount via USB, as one would expect. My error was then trying to connect to the mount via USB also, and that was the error.
For EQMac to first have the connection to the mount, a second connection directly to the mount is not possible.
THUS, the correct connection sequence it to:
1) Make the physical connection directly to the mount and computer and turn it on.
2) Launch EQMac, and wait for it to connect.
3) Launch planetarium software, and in the set up routine for the mount, you choose LX200 (or LX200GPS, both settings worked). THIS was my stumbling block. I was selecting my ACTUAL mount, and EQMac is designed to act as if it were an LX200 and translate the inputs from the planetarium software to your mount.
4) After selecting LX200, one should select German-Equatorial, if you are, in fact, not using an Alt-AZ mount.
5) Then one should use the setting for the connection to wifi or ethernet (that though me for a loop!) Using the 127.0.0.1 address and port 4030. This will seem counter-intuitive also, as you are not using a wifi connection but a USB connection but IT DOES WORK!
6) Selecting a 1 check per second is suggested by the author of EQMac, and I found no difference between the different timing settings.

So at this point, I am connecting successfully with Sky Safari to the mount. I AM still experiencing random disconnects from the mount and Sky Safari that I have to track down, but I am somewhat pleased with the success thus far.

I do wonder if my USB adapter, USB2EQ6 cable is what I think it is. FTF7HKAL shows up in a USB report, but I think that is the ID for the USB end and nothing to do beyond that connection. I am unsure if it is even relevant, as I can use the cable to drive the mount. So the random disconnects could be, and probably are, some other issue like timing or....?

thank you for taking the time to reply, and to read this far!

Re: USB2EQ6 to Mac via EQMac

Posted: Wed Oct 12, 2016 8:13 pm
by dpanderson
Good to hear you have it working now.

Enjoy!