DSUSB connection problem

Questions about hardware and software obtained directly from Shoestring Astronomy
Post Reply
whwang
Posts: 4
Joined: Thu Aug 21, 2014 3:11 am
Anti-spam question: Astronomy

DSUSB connection problem

Post by whwang » Fri Jul 15, 2022 12:30 am

Hi,

I have two similar configured Win7 computers for astrophotography. My DSUSB has worked very well on one of them for years. Recently I tried to use it on the second computer and encountered a problem.

The computer can recognize the device and the hardware properties show that it works properly. However, whenever I turn on a program that attempts to use DSUSB, the program freezes and cannot be properly launched. These include DSUSBCheck and Stark Labs DSLR Shutter. For both these programs, they either do not appear at all (DSUSBCheck) or only half of the interface is loaded. In short, they get stuck in the middle of the launching process. This doesn't change no matter how long I wait for the launching process.

What's interesting is that if I just pull DSUSB out from the USB port, both program can immediately finish launching, and they show that "DSUSB adapter found" (in DSUSBCheck's example). But of course the device is no longer there. If I plug it back, then DSUSB shows "not connected to DSUSB."

This is not likely a cable issue. I plugged the same thing to the other computer and it worked without problems.

Any suggestions on how to resolve this?

dpanderson
Site Admin
Posts: 1035
Joined: Fri Apr 28, 2006 1:34 pm
Location: central Iowa
Contact:

Re: DSUSB connection problem

Post by dpanderson » Sun Jul 17, 2022 5:28 pm

That is a strange one that I have never heard of before. I am not sure what it could be. Have you tried different USB ports on the PC that is hanging up? Do other USB devices work on that PC? Maybe try a USB hub between PC and DSUSB. Let me know if any of those options changes things.
Doug Anderson
Shoestring Astronomy
http://www.ShoestringAstronomy.com

whwang
Posts: 4
Joined: Thu Aug 21, 2014 3:11 am
Anti-spam question: Astronomy

Re: DSUSB connection problem

Post by whwang » Mon Jul 18, 2022 4:42 am

It's indeed very strange. All other USB devices work well. Here is some more information that may (or may not) be useful.

First, the computer is a Mac, running Parallels Desktop and Win7. I know people would immediately suspect that it is the Mac or the simulator. However, the other computer that has no problem at all with the DSUSB is also a Mac. The Win7 running on both Mac is a clone. (This is why I said they are similarly (if not identically) configured.). Despite this great similarity between the two, one just works, while the other has this weird problem.

To connect to DSUSB, I need a USB-C hub or a USB-C-to-A adapter. I have a few of those. I tried all of them. All work on one computer, but not on the other. For the computer that does not work, I tried putting a USB-2.0 hub and a USB-3.0 hub in between. It does not change anything. Originally I also suspected it is the connector or the hub. But these tests pretty much can rule this out. I suspect it is some subtle difference in the drivers or USB settings between the two Win7 clones made after they were cloned. Anything that I should check?

One last thing I may try is to move the good Win7 clone to the Mac with the bad clone and see if the behavior changes. Unfortunately this test will take some time to perform, as the remaining disk space may not allow the existence of a second clone.

dpanderson
Site Admin
Posts: 1035
Joined: Fri Apr 28, 2006 1:34 pm
Location: central Iowa
Contact:

Re: DSUSB connection problem

Post by dpanderson » Mon Jul 18, 2022 10:25 am

I am all out of ideas, especially since I have never dealt with Macs. Your last paragraph might work.
Doug Anderson
Shoestring Astronomy
http://www.ShoestringAstronomy.com

Post Reply