AZ EQ6-GT communication fail

Questions about hardware and software obtained directly from Shoestring Astronomy
Post Reply
SKEtrip
Posts: 2
Joined: Fri Apr 21, 2017 5:14 pm
Anti-spam question: Astronomy

AZ EQ6-GT communication fail

Post by SKEtrip » Mon May 15, 2017 3:52 pm

I'm unable to connect to the mount through Cartes and control the mount.....

ASCOM Installed
Skywatcher drivers installed
EQMOD installed
Cartes du Ciel Installed


Initially started with the Shoestring BT module - The PC can move the mount in EQMOD but the proper com ports will not come up in Cartes.
Thinking there might be a Bluetooth issue the Shoestring USB2EQ5 was ordered. Same result. Installed Sharpcap 3.0 this AM and get the exact issue where the scope connection dialogue box comes up but will not read the com port. If I input the com port in manually it is not accepted.

The same ASCOM dialogue box comes up in SharpCap and Cartes to set up the Skywatcher mount. When selecting the pull down for the COM ports it is empty and will not accept the manual input of COM 6 for the cable. (in the case of the BT unit it was COM 3.) The error message com port cannot be empty will appear after a manual attempt.

The COM ports are connected on the PC and show as functioning properly with the most current drivers. The mount will respond and run from EQMOD. The system is a laptop with Win 10 .

EQdir will not detect the mount either.

dpanderson
Site Admin
Posts: 1053
Joined: Fri Apr 28, 2006 1:34 pm
Location: central Iowa
Contact:

Re: AZ EQ6-GT communication fail

Post by dpanderson » Mon May 15, 2017 4:36 pm

It sounds like the USB2EQ5 hardware is functioning properly since you said "The mount will respond and run from EQMOD.". Have you tried posting to the EQMOD Yahoo group? There are many users there that have a variety of setups and a much better chance of finding someone that has run into a similar problem.
Doug Anderson
Shoestring Astronomy
http://www.ShoestringAstronomy.com

SKEtrip
Posts: 2
Joined: Fri Apr 21, 2017 5:14 pm
Anti-spam question: Astronomy

Re: AZ EQ6-GT communication fail

Post by SKEtrip » Tue May 16, 2017 9:18 am

Found the answers between CN and EQMOD group:

From CN
If EQMod is operating properly, then you should be good to go. From a cold boot, open Cartes Du Ciel. In the telescope settings, tell it to use ASCOM. When connecting to the telescope in the telescope control panel, select EQMod ASCOM EQ6. Click connect and you should be good to go. All the com port settings should be done using EQMod, there is no need to set this parameter anywhere else.
The mistake was trying to use the ASCOM SW -


From the EQMOD group forum -
The skywatcher ascom driver is an alternative to EQMOD and works by communicating to the synscan handcontroller (in standard mode not PC-Direct mode). EQMOD on the other hand is designed operate at the lower "motor controller" level and talks directly to the mount controller not the handset. Both drivers should be able to control your mount (but not simultaneously!) but EQMOD in driving the motors directly can offer control options that the skywatcher driver cannot access.
So there you have it - up and running! It was that simple... and in case anyone needs it: http://eq-mod.sourceforge.net/docs/E...QuickStart.pdf

The only thing that still has me guessing is why the Shoestring EQDIRcheck does not communicate with the mount.


Thanks for the response! SKE

Post Reply