Page 1 of 1

Problem with TeleVue Focus Master

Posted: Tue Jun 12, 2018 4:21 pm
by c_j_bolt
I've got a maddening problem with a TeleVue Focus Master. I can only get the application level software (i.e. FocusPal, TVFocusPlus or ASCOM via SharpCap3.1) to recognise the USB focus controller maybe once in 10 restarts of my PC. I've used USBDeview to analyse the USB devices attached to the PC, I can always see the "FocusMaster Focus Controller" device, it shows as succesfully enumerated and it is also visible as a HID device in DeviceManager (if you know which HID device to look at - need to search for the correct VID/PID). Unfortunately however, most of the time the FCUSB_DLL won't recognise the Focus Controller, and from there on its no dice.

I am a software engineer and have worked on USB HID a little bit. Is it possible that you can provide the source code for the DLL or some tips on how to fault find this? I am working on the principle that the DLL can't find the HID device for the Focus Controller - my machine does have an abundance of USB devices unfortunately.

I note that it can never seem to find the Focus Controller if it is plugged into a USB Hub, which is a pity because I want to use it on the scope, daisy chained off a USB Hub, but even getting it woking reliably off the PCs built in USB ports would be a bonus.

Obviously I have tried all permutations of ports/cables etc! In fact I have tried everything.

Oh, and I have had it working, so unfortunately I know what I am missing! Can you help me?

My PC is a Dell Laptop, 3x USB3 ports, other USB devices are ok.

Re: Problem with TeleVue Focus Master

Posted: Wed Jun 13, 2018 7:55 am
by dpanderson
Let's cover the deep software aspects via email at

As for the USB connection, a powered hub is usually best since these focus motor controllers can take the entire 100mA allowed out of the port during motor start. If your hub is powered and that doesn't help, then it sounds like your suspicions are correct.

Re: Problem with TeleVue Focus Master

Posted: Wed Jun 13, 2018 8:22 am
by c_j_bolt
Yes, my StarTech 7 port USB2.0 hub is externally powered. Normally I use a 10m cable with an active repeater between the laptop and the powered hub, then short lengths of cable off the hub to the various cameras/devices. However for my testing I have been using short cables directly connected to the built-in ports on the PC - including the high power USB port. Power definitely isn't the issue.

I'm pretty sure the DLL is at fault in this case. I'll send you an email. thanks for your assistance BTW :)